Trouble getting uLisp working on the RP2040 Zero


Pretty sure I have the correct board from the docs, littlefs I am less sure about I added the mbed version from the library manager, with out this I was getting littlefs issues.

I have the flash size set to 1mb but upload errors with Arduino/libraries/LittleFS_Mbed_RP2040/src/LittleFS_Mbed_RP2040.h:66:12: fatal error: FlashIAPBlockDevice.h: No such file or directory

Anyone able to give me any suggestions ?

Its this board I am trying to use


You should use this Arduino core, which includes the LittleFS support, and also gives much better performance than the Mbed core:

There are full instructions on this page: RP2040 Boards

Let me know if that doesn’t fix the problem.


I am pretty sure I have done that step, the screenshot above includes the installed version I believe I have the correct board selected as well, I removed the mbed version which I had previously installed.

or are there different versions of earlephilhower/arduino-pico but I pasted in the url into the prefs page and installed the new version.


Ah yes, I see now that you were using the correct core; I was confused by Mbed in the pathname.

I haven’t tried Arduino IDE 2.0.3. Could you try an earlier version of the IDE, such as 1.8.15? I know that works.


I’ve just confirmed that I can get uLisp ARM version 4.3a to compile without errors with the Waveshare RP2040 Zero board settings, and version 2.7.0 of the Earle F. Philhower core.

You need to add these #defines to the start of the uLisp source:

#define LED_BUILTIN 16

I used Arduino IDE 1.8.13. I haven’t tried version 2.0.3.

Set Flash Size to 2MB (Sketch: 1MB, FS: 1MB).

Let me know if you get it working.


Thanks that works a treat / it now compiles and uploads with arduino 1.8 it does not work with arduino 2 however complaining of a missing binary rp2040/tools/pqt-gcc/1.5.0-a-5007782/bin/arm-none-eabi-g++ but not fussed about the version just happy it works now so thanks for the assistance.


Might be useful to report that to Earle F. Philhower on the GitHub page.