ESP32 compile error


Hi all
trying to compile last ulisp for esp 32 devkitc v2 on a rasperrypi 3
but i have this error
in function void autorunimage()
invalid conversion from ‘int’ to ‘builtin_t’ [-fpermissive]

anyone can help ?



Change the line:

apply(0, autorun, NULL, NULL);


apply(NIL, autorun, NULL, NULL);

Sorry about that problem; I’ll release a fixed version soon.


hi david
same error in EEPROM.BEGIN function
i applied the same correction as autorun function
but another error comes out
4398:29: error: ‘LED_BUILTIN’ was not declared in this scope
{ string219, (fn_ptr_type)LED_BUILTIN, 0 },


Sorry, I forgot about that. Add the line:

#define LED_BUILTIN 13

somewhere near the start of the source.

TTGO T-Display setup and speed problem

The board im using dont have a led onboard !!!
Dont know if this causes the error in compilation.
If i use the blink example in arduino ide i have the same error
LED_BUIlTIN not defined.
thanks for the help
love ulisp


Yes, it’s not defined in the Arduino Core for ESP32, but the latest uLisp assumes it is (because it’s defined for most other cores), so adding that line will enable uLisp to compile without error.



Fixed in ESP uLisp 4.0b.