ESP8266 compile error


I get this error : ‘pfstring’ was not declared in this scope; did you mean ‘pstring’?


Funnily enough I encountered this yesterday while experimenting with the ESP8266. Something’s changed in the Arduino Core, causing this.

The solution is to add this line:

void pfstring (PGM_P s, pfun_t pfun);

after the heading:

// Forward references

I’ll release a fixed version soon.


Thanks David,

Now it compiles.
I selected the LOLIN (Wemos) D1 mini pro and try all baudrates with the serial monitor
The best result at 74880baud is this

If i choose the generic ESP8266 at 9600baud it works
Missing the extra flash from the pro now.


I selected the LOLIN (Wemos) D1 mini pro and try all baudrates with the serial monitor

I don’t quite understand what the problem is. Are you saying it won’t work with the “LOLIN (Wemos) D1 mini pro” board option?


Indeed David,

The pro version is not working and I don’t understand the error message


Can you upload Arduino examples, such as “Blink”, OK.

uLisp will only work with the Serial Monitor set to 9600 baud. What happens if you do that?


With the blink from arduino basic examples i get kind of same error message, only with a different checksum, also only at 74880 baud, all other baudrates give unreadable text.


There’s an Upload Speed option on the Tools menu. Try a lower speed, such as 57600. It looks like you’re getting checksum errors (nothing to do with uLisp).



No improvement David.

It does succeed to upload at a higher speed for the generic esp8266, so i don’t think that the speed is the reason for the checksum errors.




There were issues with the 16Mb version in the past,
but they are solved since 2017



As the problem also occurs with Blink it’s a general problem with the Arduino core, so you could report it here:


Will do David,

When it’s solved will post it here.
Thanks for you time and advice

Kind regards,



The ‘pfstring’ error is fixed in ESP Version 3.6b, available here: Download uLisp